문제 링크
https://www.acmicpc.net/problem/6135
문제
Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.
Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.
The cows' practice room has N (1 <= N <= 300) stations, conveniently labeled 1..N. A set of M (1 <= M <= 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station S_i to station E_i and contains exactly one hurdle of height H_i (1 <= H_i <= 1,000,000). Cows must jump hurdles in any path they traverse.
The cows have T (1 <= T <= 40,000) tasks to complete. Task i comprises two distinct numbers, A_i and B_i (1 <= A_i <= N; 1 <= B_i <= N), which connote that a cow has to travel from station A_i to station B_i (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from A_i to B_i. Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.
입력
- Line 1: Three space-separated integers: N, M, and T
- Lines 2..M+1: Line i+1 contains three space-separated integers: S_i, E_i, and H_i
- Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: A_i and B_i
출력
- Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.
예제 입력 1
5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1
예제 출력 1
4
8
-1
알고리즘 분류
- 최단 거리 알고리즘
풀이
플로이드-와샬 알고리즘을 사용하여 최단 거리가 아니라, 경로 상의 장애물의 최대 높이의 최솟값을 기록한다.
경로가 없는 경우에는 -1을 출력한다.
코드
#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#define MAX 301
#define INF 1e9
#define LL long long
#define FASTIO cin.tie(0); cout.tie(0);
using namespace std;
int N, M, T;
int Height[MAX][MAX];
void init() {
for (int i = 1; i <= N; i++) {
for (int j = 1; j <= N; j++) {
if (i == j) {
continue;
}
Height[i][j] = INF;
}
}
}
void floyd_Warshall() {
for (int k = 1; k <= N; k++) {
for (int i = 1; i <= N; i++) {
for (int j = 1; j <= N; j++) {
int Next = max(Height[i][k], Height[k][j]);
Height[i][j] = min(Height[i][j], Next);
}
}
}
}
void input() {
cin >> N >> M >> T;
init();
while (M--) {
int S, E, H;
cin >> S >> E >> H;;
Height[S][E] = H;
};
floyd_Warshall();
while (T--) {
int A, B;
cin >> A >> B;
if (Height[A][B] == INF) {
cout << "-1\n";
}
else {
cout << Height[A][B] << "\n";
}
};
}
int main() {
FASTIO
input();
return 0;
}
'BOJ > Gold' 카테고리의 다른 글
[BOJ/Gold 5] 백준 20208 진우의 민트초코우유(C++) (0) | 2022.12.24 |
---|---|
[BOJ/Gold 5] 백준 19942 다이어트(C++) (0) | 2022.12.12 |
[BOJ/Gold 4] 백준 9870 Vacation Planning(C++) (1) | 2022.12.07 |
[BOJ/Gold 5] 백준 14588 Line Friends (Small)(C++) (0) | 2022.12.05 |
[BOJ/Gold 5] 백준 11265 끝나지 않는 파티(C++) (1) | 2022.12.05 |